Impossible d'envoyer un message / sauvegarder un message


#1

J’ai rencontré un horrible bug ! :cold_sweat:

Lorsque je compose un message, si je clique sur envoyer / sauvegarder ou si j’attends l’autosave, le message d’erreur suivant apparaît en haut à droite :

Sorry, an unexptected error occured. developers will work hard on this error during alpha phase. Please feel free to describe us what happened.
  • Système d’exploitation utilisé : j’ai testé sur Ubuntu 17.10, Windows 7, Android sur un tablette
  • Navigateur utilisé : Opera 49 / Firefox 57 / Chromium
  • Message dans la console (si vous êtes familier avec la console) : voir plus bas
  • Pour reproduire ce bug il faut : se connecter à l’interface puis cliquer sur Ecrire, entrer l’adresse mail d’un correspondant par ex, un sujet, un corps de message, cliquer sur Sauvegarder ou Envoyer

Messages dans la console :
POST https://alpha.caliopen.org/api/v1/messages 520 (unknown)
et
Uncaught (in promise) {type: "co/message/CREATE_MESSAGE_FAIL", error: Error: Request failed with status code 520
at t.exports (https://alpha.caliopen.org/assets/vendo…, meta: {…}}

Je peux donner plus d’infos si besoin.

J’ai un peu le sentiment que ça peut aussi être lié à cet autre bug que je rencontre et qui ne me permet pas non plus d’afficher une discussion…
Ce qui est bizarre c’est qu’il semblerait que personne d’autre soit affecté, donc ça serait lié à mon compte plus spécifiquement ?

Assez frustant car à ce jour je ne peux pas vraiment tester l’outil puisque je ne peux pas :

  • afficher une discussion
  • écrire et envoyer un message

#2

Bonjour,
merci de nous avoir signalé les problèmes que vous rencontrez. Nous essayons de les reproduire… Mais nous n’y arrivons pas !
À ce jour, l’envoi des messages fonctionne pour l’essentiel. Nous allons essayer de retrouver les traces de vos problèmes dans les logs de nos serveurs. À l’avenir, auriez-vous la gentillesse de nous donner des indications horaires lorsque nous vous envoyez les copies des messages d’erreur.

Merci,
Cordialement,
Caliopen.


#3

Bonjour,

En fait j’ai peut être pas précisé que pour moi ce bug se reproduit systématiquement en fait.
C’est à dire que ça fait plusieurs jours que ça fait ça à chaque fois. J’ai pris le temps d’attendre un peu pour voir si ça évolue (je sais que vous bossez dur dessus) et si j’arrivais à ne pas rencontrer ce bug sur d’autres OS/navigateur mais je rencontre systématiquement le même problème.

Par exemple là à 10h15 je viens de le faire: j’ai cliqué sur Ecrire, entré un contact, un titre et un corps de message, puis le message d’erreur est apparu lorsque la sauvegarde automatique a tenté de sauver le brouillon, puis j’ai cliqué sur envoyer, idem, même message, puis j’ai cliqué sur sauvegarder, idem même message.

Peut être que je peux créer un nouveau compte pour voir ce qu’il se passe ? mais il y a une histoire d’invitation non ?


#4

Pourriez-vous nous dire si vous avez supprimé la fiche « contact » de vous-même, c’est-à-dire la première fiche contact qui a été automatiquement créée à l’ouverture de votre compte ?


#5

ah j’ai effectivement eu 0 contacts dans ma liste à un moment… je ne savais pas qu’il y avait un contact qui correspondait à moi-même (edit: enfin “j’ai pas fait gaffe” serait plus juste), donc cette fiche a sûrement été supprimée !

Peut être qu’il faut la rendre insupprimable :grimacing: ?


#6

Oui, le problème vient de là. J’ouvre un issue sur github et on trouve une solution le plus rapidement possible.
Dans l’attente, je vais essayer de vous recréer cette fiche contact initiale pour que vous puissiez à nouveau utiliser l’application.


#7

pouvez-vous me confirmer que votre n° d’utilisateur est bien : da218426-499e-42be-aad1-c378ffdafea8


#8

Pouvez-vous me dire où le trouver ?


#9

votre compte est-il bien raphm@alpha.caliopen.org ?


#10

oui c’est bien mon compte


#11

nous avons recréé un contact vide associé à votre utilisateur. Est-ce que cela débloque votre situation ?


#12

Oui complètement: je peux écrire des messages, sauvegarder, envoyer, et donc aussi afficher les discussions.
Super, merci beaucoup.


Les discussions ne s'affichent pas (page vide)
#13

J’ai la même chose qui se produit. Et je ne vois aucun bouton pour afficher la liste des contacts;

Système d’exploitation utilisé :Ubuntu 17.04
Navigateur utilisé : Firefox 58.0.2
Message dans la console (si vous êtes familier avec la console) : ??
Pour reproduire ce bug il faut : se connecter à l’interface puis cliquer sur Ecrire, entrer l’adresse mail d’un correspondant par ex, un sujet, un corps de message, cliquer sur Sauvegarder ou Envoyer

Ce n’est pas systématique mais plus le message est long plus ça a des chances d’arriver.
Pour l’instant ma parade, c’est de copier mon message, fermer la conversation puis refaire une réponse en collant et en envoyant immédiatement !
Merci pour votre soutien.


#14

merci de ce retour @vicomtegaston nous avons travaillé à nouveau sur la sauvegarde et sera bientôt disponible.

En attendant j’essaie de reproduire (mais ma connaissance du fonctionnement interne ne m’aide pas forcément à trouver l’erreur), j’en ai bien une au niveau de la sauvegarde automatique mais pas manuelle.

Il faudrait m’indiquer quel est le message d’erreur, il y en a deux possible qui s’affichent dans une notification :

soit

Sorry, an unexptected error occured. developers will work hard on this error during alpha phase. Please feel free to describe us what happened.

soit

La sauvegarde n’a pas pu être réalisée


#15

Bonjour,
Désolé pour mon long silence;
Je reviens sur le sujet et j’ai fait une capture d’écran


Pour mémoire, je suis sous Firefox Quantum 60.0.2 - Mozilla Firefox pour Ubuntu Canonical - 1.0


#16

Mon compte est : vicomtegaston@alpha.caliopen.org.
N’est-ce pas ce souci de contact “moi-même” supprimé, comme Raphm ?
L’icône de contact (? - le petit bonhomme) m’ouvre un menu “Compte - Paramètres - Déconnexion”. Je ne sais où trouver mes contacts et j’en ai pourtant au moins un !
Merci par avance pour votre soutien


#17

Oups ! J’ai trouver comment afficher les contacts. Et j’en fait bien partie avec mon adresse courriel de secours.
Réédition pour répondre au message ci-après:
J’ai réessayé plusieurs fois sans succès, ni rafraîchissement, ni déconnexion reconnexion ne changent le résultat
2° réédition :
Je ne vois pas comment un rafraichissement peut-il être “complet” ?
Je rafraichis en utilisant la flèche circulaire de l’onglet. Que faudrait-il faire de plus, SVP ?


#18

merci pour ce retour.
Il faudrait essayer de sauver à nouveau le brouillon après un rafraichissement complet de la discussion.

Est-ce que le problème persiste ?